Black screen at startup - mobile remote

first of all, I would like to thank everyone who dedicates their free time to supporting and developing this program.
I am a beginner and I want to set up a simple system of congregational singing in our church. We got a bigger tv and intel NUC computer. I installed Ubuntu (I’m also a complete beginner here since I am Windows user) and Quele on it.
I set up a wi-fi access point on the ubuntu computer, which is only connected to the tv screen, because we don’t have a router in the church. On his Wifi, I connected an android 11RKQ phone with the Mobile remote app installed. In Quelea server setting I changed password of mobile remote to “1”.
When I restarted Quele on the computer to apply the server changes, I only got a black screen and no key worked anymore. Pressing Winows key shows quelea black screen and inscription “video”. I have closed program and tried again. This time getting “It looks like you already have in instance of Quelea running…”
I found a conversation about a similar problem and renamed the .quelea folder, which solved the problem until I tried to set up remote control again. Sendig debug file over email.
I did the same on my personal laptop with Windows 11. This time it didn’t show a black screen, but the Android phone with Mobile remote app on, which is on the same Wifi hotspot as laptop, refuses to connect to the program at the ip address displayed in the Quele server settings. I can’t even access the IP address through a browser.
Do you have any idea what could be wrong with ubuntu and what am I doing wrong that I can’t set up Mobile remote?
Thanks in advance.

ps. I would like to translate the user interface into Slovenian. Are there any files to translate?