Issue with importing qsp database


I have issue importing qsp exported database into qualea. In qualea 2019.2 version I have exported whole database into qsp and when i tried to import it in 2024.0 I’n not able to import it.

I have performed windows reinstall and before than I exported Qualea DB into qsp file and than after reinstall I’ve tried to import it into Qualea but the import was not successful.

Can you please help me with the issue?

Thank you, Michal

If not private, would you post (or post link) to the database.
The database format is just a zip containing files. You can still access them.
I have previously written deduplication scripts (and some analysis) for the database files.
We can check the files, see if there is some incompatibility, maybe ask chatGPT (lazy-lazy) for a quick script to correct your files => repackage => import => happiness!
… well you can even try to load it into an older version and rexport and try the next version (import - re-export) might fix any incompatibility along the way … but it’s just faster to get the files and figure out if it’s some XLM tag giving grief.

Hi Jessy,

Thank you for suggesting the script idea! I hadn’t thought about that, and I’ll definitely check it out.

If you’re interested in trying one of your own, here’s the link to the database: backup_3_24.qsp - Google Drive

Thanks again, Michal

This is what my export of the database looks like:

This is yours:

One possibility is difference in format and i am not so sure about that. The more likely case, is your file is potentially corrupted.

It was corrupted. I fixed them for you. Here you go:

Congrats on the free data recovery services.

1 Like