Quelea failing to launch

Hi! Long-time Quelea user here. So appreciate this app and this community.

I’ve just downloaded and installed version 2020.0 on a Macbook running OSX Mojave 10.14.6. My Java version is Java 8 update 261.

I have been unable to get either the Mac version or the Cross-platform to launch. Nor am I able to launch any of the previously working Quelea installations.

I receive this error: java quit unexpectedly

My crash report includes:

Application Specific Information:
*** Terminating app due to uncaught exception ‘NSInternalInconsistencyException’, reason: ‘NSWindow drag regions should only be invalidated on the Main Thread!’
terminating with uncaught exception of type NSException
abort() called

Application Specific Backtrace 1:
0 CoreFoundation 0x00007fff524d6acd __exceptionPreprocess + 256
1 libobjc.A.dylib 0x00007fff7cbb3a17 objc_exception_throw + 48
2 CoreFoundation 0x00007fff524f0629 -[NSException raise] + 9
3 AppKit 0x00007fff4fa955ca -[NSWindow(NSWindow_Theme) _postWindowNeedsToResetDragMarginsUnlessPostingDisabled] + 317
4 AppKit 0x00007fff4fa929f7 -[NSWindow _initContent:styleMask:backing:defer:contentView:] + 1479
5 AppKit 0x00007fff4fa9242a -[NSWindow initWithContentRect:styleMask:backing:defer:] + 45
6 libAVPlayerJava.jnilib 0x000000012cc12a52 +[AVPlayerJava start] + 242
7 libAVPlayerJava.jnilib 0x000000012cc16955 JNI_OnLoad + 69
8 libjava.dylib 0x000000010bc0d7f5 Java_java_lang_ClassLoader_00024NativeLibrary_load + 195
9 ??? 0x00000001133b66c7 0x0 + 4617627335
10 ??? 0x00000001133a62bd 0x0 + 4617560765

Debug Log

Aug 31, 2020 8:23:55 PM org.quelea.services.languages.LabelGrabber
INFO: Using languages file /Applications/Quelea2020/languages/gb.lang

Aug 31, 2020 8:23:55 PM org.quelea.services.languages.LabelGrabber
INFO: Setting en-uk locale

Aug 31, 2020 8:23:55 PM org.quelea.windows.main.Main start
INFO: Started, version 2020.0

Aug 31, 2020 8:23:55 PM org.quelea.windows.main.Main start
INFO: OS name: Mac OS X

Aug 31, 2020 8:23:55 PM org.quelea.windows.main.Main start
INFO: Using JAVA version 1.8.0_261

Aug 31, 2020 8:23:55 PM org.quelea.windows.main.Main start
INFO: 64-bit: true

Any help would be greatly appreciated.

Any help would be greatly appreciated? Or if I’ve I come to the wrong place for this type of question, please point me in the right direction? I am in full-time ministry and use Quelea extensively. Right now none of my versions of Quelea will open. I’m a bit stuck. Thanks!

Hey! Sorry for the delay, all the developers have been rather busy as of late. The issue with diagnosing Mac problems is that none of the Quelea developers have a mac, so this can be a bit tricky. Can you try fully removing Quelea and then installing 2019.1 to get that working again? I’m a bit stumped if 2019.1 worked before and doesn’t work now, as that implies some kind of configuration has changed somewhere.

Also, what version of MacOS are you running?

Hey berry120, thanks for the help. I’m running a Macbook Pro with Mojave 10.14.6.

Good news! A bit before you posted your reply I succeeded in getting Quelea working again. Here’s what I did:

First, I uninstalled Java via the command line:

  • sudo rm -fr /Library/Internet\ Plug-Ins/JavaAppletPlugin.plugin
  • sudo rm -fr /Library/PreferencePanes/JavaControlPanel.prefpane

Then I reinstalled an older version of Java Runtime Environment (8u161). All of my Quelea installs worked immediately.

Just to see what would happen, I then upgraded JRE to the latest version. Immediately everything returned to crashing.

I then went through the same procedure of uninstalling JRE from the command line and reinstalling JRE 8u161. Everything returned to working.

Great to hear, and well done!

Sounds like we have a compatibility issue with Macs and the latest version of Java 8, but unfortunately that looks like it’s going to be a bit of a nightmare to track down. I’ll make a mental note of it and if I get my hands on a Mac, I’ll see what I can do about reproducing it (and hopefully fixing it if possible.)

Thanks for your attentiveness to this issue. I appreciate this community and the work of the development team. I have checked out many worship projection applications. Quelea is my go to for many reasons. Now that I can run 2020 I’ve got to give you guys kudos for a fantastic upgrade. The Well done! Song Sequence has been at the top of many wishlists. Planning Center import is HUGELY helpful I also appreciate the expanded Documentation. Keep up the great work and know that your efforts are making a difference.

Hi there!

Any news on the Java 8 and Mac issue?

I am getting the same error message and I’ve been using Quelea for at least 2 years without issues.
But whenever I did the Java update it just keeps crashing. What can be done? Is there maybe a way to reverse the update? Or something else ? 2020 Quelea Version won’t start up either.

Hi Vera!

I think I can help you. I have successfully gotten Quelea 2020.0 running on my OSX system and that of a colleague after encountering this crash issue. The problem seems to be with the latest version of Java (8 update 261). The answer is to install an early version of Java and not to update. For now anyway, until the bug is fixed.

I shared the steps in an earlier post, but here’s what you need to do:

Uninstall Java. You can do this easily and completely from the command line using Terminal.

  • Open Terminal (a native OSX application)
  • Run the following commands from the command line
  • sudo rm -fr /Library/Internet\ Plug-Ins/JavaAppletPlugin.plugin
  • sudo rm -fr /Library/PreferencePanes/JavaControlPanel.prefpane

Install Java 8 update 161

Once you’ve taken these steps, all of your versions of Quelea should work fine. Good luck!

Hi everyone,

Good news - one of our users believes he’s been able to isolate & fix the issue, and so this should now be fixed in the latest CI release (available here: Release CI-RELEASE · quelea-projection/Quelea · GitHub)

If you could all take a look and confirm whether the fix works for you, that’d be fantastic - if so then hopefully we can get mark this as fixed for the 2021.0 release :+1:

Quick update. 2021 successfully launches and seems to run fine with the latest Java update. Well done!