Quelea Update

Hello, I want to ask question here.

I want to use updated Quelea, currently I am using 2016 version. What I am doing was installing the Quelea 2019 version. Good thing all the DB was still there.
But when I see on my installed apps seems the 2016 not overwritten and the system recognize 2 Quelea, 2016 and 2019 version. Is it gonna be a problem if I uninstalled the 2016 one?

Note: I am using Windows 7
And maybe gonna try using 2019.2 also :smiley:

Thanks in advance!

2019.2 doesn’t exist! You may mean 2019.1 :slight_smile:

But yes, there should be no problem at all with you uninstalling 2016 once 2019 is installed.

Ups… I mean 2019.1 beta 2 hahaha
Good then! Thanks for helping :smiley:

I am allmost at the same hurdle as cloun, but one stage earlier in the process.
On Windows I have 2016.01 installed (That’s what the window caption and the about box shows, the splash window shows a big ß). I try to update it to 2019.1.
Update from within Quelea does not work. It tells me to check my internet connection, but that’s ok, and I am not using a proxy. (Would this need a windows firewall exception).

Anyway, I tried to update manually, downloading the installer. There’s only a x64 installer (The doc says: “… even if you are running on a 64 bit machine, since the JRE bundled with Quelea is also 32 bit.”. So obviously it must run on 32.bit Windows. What’s wrong? I intend to run this on a 32-bit system (I do not have 64-bit drivers for all system devices).

So I download the installer anyway. The installer .exe is a 32-bit executable! does it really install on a 64-bit Machine only? I check the contents of the installer .exe, and there’s a 64-bit IRE bundled ==> please update the documentation (is there a 64-bit VLC installatiuon required also?)

Is support for x86 dropped, or could someone provide me with a current x86 version? If it is dropped, why is there no mention in the change log?

So I go back in time, searching for the most recent x86 installer (2018.1) and download it.

When running the installer, it suggests to install to a default location (My current version is installed to different location). When I change the Installation path, it complains, that the folder exists already. (This does not really suggest the installer is aware that I want to update.) Then it does not pick up the start menu folder from my existing installation either.

So I decide to abort that installation. It does not look like the installer knows what it is doing. Seeing the question by cloun confirms my apprehension that this would create a mess of my system.

So here are my quintessential questions.

  • Is there a version of Quelea which I can run on my System (Windows 8.1 x86)
  • How do I install it? can I update or do I need to uninstall my old version first? If the latter, will my settings and resources be preserved? If no, how do I save them, and how do I restore them into the new version?

And here some requests

  • please keep the doc up-to-date
  • please mention, how to update in the docs
  • handle updates from the installer properly or refer the user to the update documentation if it detects an installed version on the system
  • help people find the latest versions suitable for certain versions of the OS

That’s correct, Quelea cannot be upgraded directly from the software. It should however take to you the site for downloading the update and manually installing it.

If my memory isn’t completely failing me (you can correct me if I’m wrong here, @berry120), x86 support was dropped when we tried to move to a newer version of Java since Java 9+ only supports 64-bit systems. As we had some issues with newer Java versions, we ultimately returned to Java 8 but I suppose we never added the x86 build back.

There’s no x86 Windows build for the latest release at the moment. You can still install Quelea 2018.1 x86 if you want. However, if you install Java 8 manually, you should be able to install the latest version using the cross-platform version.

Basically, the path where Quelea is installed is different from the path where the settings and all other resources are stored. An update means overwriting the data in the software path but leaving the database directory untouched (meaning that it’s OK to continue the installation after that warning) since no data will be lost. In fact, you could even uninstall Quelea and your database directory should still be there. If you would prefer to make a backup first, it should be located in: C:/Users/USERNAME/.quelea

I agree. We try to do that, but sometimes we don’t remember to change all the pages. If you spot anything like that, feel free to make a pull request to the docs. We appreciate all the help we could get there!

I’ll leave this to @berry120 to comment on, but I think there’s a limitation in the library we use to create the installer for it to recognize it as an update. We should however add something about the update process in the documentation.

We have links for all other operating systems here, but it would be nice if GitHub would have a feature to suggest a version based on the current OS. I remember SourceForge had that feature back when we had our code there, but I’m not sure if there is something similar on GitHub.

Arvid is correct - we dropped support for x86 when we were looking at upgrading to Java 11, and didn’t add that back in. Since Quelea is designed for newer systems, and all newer systems have been 64 bit for a long while now, there seems limited usefulness in maintaining a separate x86 release for (what would probably amount to) just a little bit longer. If you spot mistakes in the docs, omissions from the changelogs, etc. then please create a PR on Github so we can take a look! We do what we can but inevitably various bits and pieces will get missed off from time to time.

The installation issue with upgrades is likely an issue with the installer library we’re using (or more likely the way we’ve got it configured currently.) We may have a poke around at some point and see if that’s something we can resolve easily, but it’s unlikely to be a high priority.

Thanks,

Michael

Thanks for your answers.

I installed now using the cross platform installer. It runs so far. I will now have to explore the app.

I installed into a new folder. The installer did overwrite the uninstall entry in the registry, but left the old installation intact. Looking at the 2016.1 program folder, that version might have come from the cross platform installer also. There is no .exe in the folder, unlike the current windows installer.

Both @ArvidNy and @berry120 talk about doing a pull request. Although I am a programmer, I am not familiar with GitHub’s pull requests. However, as I understand a pull request, it is a request to get changed files from me. But how and why should I change files for public consumption knowing very little to nothing about Quelea and how it is supposed to be working? I can’t do much more than telling the experts where I have found problems.

Glad to hear you managed to install it now!

Oh, we must have misunderstood you. When you wrote “please mention, how to update in the docs”, I thought you wanted to make some adjustments yourself. Of course we also appreciate if you tell us what the errors you have found and we’ll adjust them when we can.