Video freeze while playback 2024.0

Hi, I recently installed the quelea update 2024.0, while a video is playing, the video suddenly slows down and starts to have cuts and stops and then continues again. I installed the gstreamer components and reset the device but i still have the same problem.
After i installed the previous version (2022.0) I didn’t have that problem. My quelea runs with Win 11, and my hardware is AMD ryzn 7 5700G, 16gb ram.

Hey, do you have a link to the video file you’re using, or one that causes the issue? I’ll look into it.

I download tracks from youtube with 4k Video Downloader, I download the videos in 1080p mp4 format.
When I play videos with quelea i have problems but if i play with vlc or others i don,t have it.

Here you are a example link

Thanks, I’ve requested access. How long (roughly) did you need to leave the video playing before you noticed the issue?

The error is random, there are times when the video plays fine until the end, but there are times when it freezes in the middle of the song or the beginning.

Hmm, that’s a pain, random errors are always harder to track down. I’ve just played it through once and it’s worked fine for me.

Trying to extrapolate patterns:

  • Is it completely random or is it more likely to occur under any circumstances, like if Quelea has been open a while, there’s more in the schedule, etc.
  • Is it noticeably worse / better if the resolution changes, i.e. between SD or HD content and 4K content?

I’m going to do some more extensive testing, I’ve only tested it for 2 services. And both times they have failed. I think that to examine what you tell me I must try it better. I will be informing you about this.

Thanks very much - keep me in the loop and I’ll do what I can to fix it.

@DeeTigIT Just tagging you in case you happen to have a chance to see if you can reproduce anything like this - you’re a much more thorough tester than I am!

Tito:

  • Thanks for sharing the link!
  • Unfortunately, I haven’t been able to reproduce the issue.
  • Could you check your CPU/GPU/memory usage during these events?
  • Which Quelea version are you using: the cross-platform or the windows installer?
  • And which GStreamer version did you install: gstreamer-1.0-msvc-x86_64-1.22.9.msi ?

Hi, DeeTigIT, im using the windws installer and gstreamer MSVC 64-bit (VS 2019, Release CRT),
gstreamer-1.0-msvc-x86_64-1.22.9.msi.
I will not have access to the church equipment for a few days. At the moment I am doing my checks on my home equipment.
My response will take a few days. Regards

Now from my laptop I am doing tests, to be able to replicate the error with another of the videos that gave me problems. In this case I have not had any problems with the playback. For 1 hour I have been playing the videos and exchanging them with a lyric with a video background. And I haven’t noticed any cuts or failures. But suddenly when editing the song with the video in the background while playing a video in quelea which it started to consume too many PC resources, both CPU and Memory. And to give the previously mentioned failures. up to a point where the queue became slow and the videos stopped being fluid.
I am carrying out the test in Win 10 with an EliteBook i7 5600u and 16gb ram. With the quelea and Gstreamer installation program previously mentioned in the previous message.
I leave you some images where I only have an open Chrome window and the one that reads only with 3 articles in the script, 2 letters with a background video and 1 video with music. I leave you a couple of photographs of what my PC was doing. I don’t know if the use of resources is normal.


Thanks for the investigation - in short no, that’s not normal (at least on my machine - I see around 7% CPU usage doing the same thing as you there.)

Curious if this is something Dirk is able to reproduce his end…!

Mm. There seems indeed to be a relation with the song editor window. When I play the shared video on the live panel AND at the same time edit a video-themed song in the preview pane: at some time during the editing process the lagging and stuttering begins on both de preview and the live panel video’s.
My CPU and memory usage don’t go that high, however. (I have a dedicated GPU and more mem).
The program can’t recover from this situation it seems and has to be restarted: cancelling the song editor has no effect.
I observed that (quickly) moving or resizing the initial editor window, without starting editing, shows an accidental stutter after which the video continues.
I also noted that editing a imaged-themed song in the preview panel, while playing the shared video, does not give this issue (at least for the time I tried editing).

Hello again, I have carried out the tests with the church setup.
he has done the same problem again In this case I have realized that these errors happen every time I exchange a lyric with a background video and a video. In our script we always have lyrics with a video as background and when a singer wants to sing their track and see the lyrics projected on the screen at the beginning or in the middle of the song, cuts happend The CPU and memory, it has not exceeded 20%. I don’t know if it is a problem with our PC or software performance issues with the prewiews issue.

I’ve switched things around in the latest CI release with some very experimental rendering code that should be a bit more efficient. If you could give it a try and let me know that’d be great.

(It may just break entirely though - be warned.)

Using the CI cross-platform I get this error.
I’m using JAVA version 11.0.21

C:\Program Files\Quelea CI-release>call Quelea.bat

C:\Program Files\Quelea CI-release>java --add-exports=javafx.graphics/com.sun.javafx.css=ALL-UNNAMED --add-exports=javafx.base/com.sun.javafx.runtime=ALL-UNNAMED --add-exports=javafx.base/com.sun.javafx.event=ALL-UNNAMED --add-opens java.base/java.lang=ALL-UNNAMED --add-opens javafx.controls/javafx.scene.control=ALL-UNNAMED -Dfile.encoding=UTF-8 -Dprism.dirtyopts=false -jar Quelea.jar
WARNING: Unknown module: javafx.graphics specified to --add-exports
WARNING: Unknown module: javafx.base specified to --add-exports
WARNING: Unknown module: javafx.base specified to --add-exports
WARNING: Unknown module: javafx.controls specified to --add-opens
Error: LinkageError occurred while loading main class org.quelea.windows.main.MainStub
java.lang.UnsupportedClassVersionError: org/quelea/windows/main/MainStub has been compiled by a more recent version of the Java Runtime (class file version 65.0), this version of the Java Runtime only recognizes class file versions up to 55.0

C:\Program Files\Quelea CI-release>pause
Press any key to continue . . .

Hi Dirk,

Quelea 2024.1 now needs Java 21 - I’d recommend one of the Azul JDKs with JavaFX bundled in: https://www.azul.com/downloads/?version=java-21-lts&package=jdk-fx#zulu

We should definitely make this clearer somewhere though.

Thanks,

Michael

I added a comment to:

Thanks - should be fixed in the latest CI.