Lagging on 2019

#1

Hi There
Our 2019 version is lagging by about 1 to 2 seconds before the next slide displays and it take a while to load. can it be hardware?

#2

Load meaning to startup

#3

It could be - couple of questions:

  1. Is this any better with the 2019.1 beta?
  2. Is this a regression (it was fine with 2018.1 and isn’t now), or is 2019.0 the first version you’ve tried?
#4

This is the first version I have tried and I am also facing similar problems. When running the software, entire system lags for 1-2 seconds in between the slides/

#5

Hmm, it certainly shouldn’t lag that much unless your system is really slow. Does the 2019.1 beta offer any impovement? Does the type of background / font etc. make any difference to the lag?

#6

@ArvidNy Now I think of it, do I recall that you had a similar issue at some point - did we ever fix it, or am I going mad and getting confused with something else?

#7

was better on 2018.1. Have not tried the new beta yet. However the startup does take some time. have to be honest we are still on an old pc

#8

That’s correct, @berry120. For us it was also a hardware related issue. The uniform font size option was what made it really slow between the slides, so disabling that might help. However, that should be improved in 2019.0, so if 2018.1 is better for you, that’s strange!

Regarding the startup time, that’s because everything is buffered into memory to avoid having to wait for long periods of time while you are using the software live, but I know that it could even take minutes with old hardware for it to load completely. With slightly better hardware the startup time should be a lot shorter (for me it’s only about 10 seconds).

#9

That sounds about right - and yes startup time will just be slow with a combination of a slower PC & large database (upgrading to an SSD is likely to help in this regard, if you’re able.)

Does switching uniform font size on/off make a difference at all?

#10

@shreyas.gangwar Out of interest are you also on old hardware, or something more modern?

#11

dual core pentium

500gig hdd

2gig ram

#12

i5 5th gen
1 Tb Shdd
8gb Ram

#13

A dual-core processor is what we used as well when we experienced this, but I don’t think a quad-core i5 should have this issue. I suppose disabling uniform font size didn’t make a difference for either of you? Could you perhaps attach the debug log and possibly also a screen recording of the issue if that could give us any other clues?

#14

As @ArvidNy said, the uniform font size option is the key one here (we need to know if it made a difference or not to know where to look in the code for the problem), and the debug log would be great too.

I agree that an old dual core pentium is pushing it a bit when it comes to running Quelea, but any i5 or above should be fine.