Motion background is not fullscreen on the projector screen

Hi,
I recently installed quelea and it looks great.
But I encounter one big problem for me. For different songs I took the video background option. But when I hit “Go Live” the lyrics show on the full screen, but the motion background video only show in the top-left corner, filling a little more the half the screen.

I have spend hours trying to see how I can fix this. Is there a solution in Quelea itself, or is the solution in the VLC player?

Looking forward to the help I need. Thanks.

When I play the video itself, it is also about half screen in the top-left corner. Beyond that I see my extended desktop background.

Images however show full screen.

And if I play the video mp4 file in VLC then full screen is no problem at all

Some users have reported issues similar to this when scaling is enabled in Windows. Does it behave the same way if you disable scaling?

Thanks for your reply

How do I disable scaling?

Just change the option “Change the size of text, apps and other items” to 100%. See this article on how to locate it. Note that you should be able to set the scaling for your computer screen and projector screen separately. Decreasing the resolution might also be an option.

I came across this article and just recently started using Quelea and noticed the same issue no matter the monitor, resolution and even tried the scaling with 100% producing the same results. If I adjust to anything else it does tend to make the smaller video show up in different spots on the screen. Using it for songs the song text is full screen over a small video usually in the top left or left middle.

Has there been ANY updates to this issue or settings in VLC I can possibly adjust?

I got this figured out after some digging on how to fix VLC and stumbled on the setting for Windows 10 to override the High DPI scaling. It’s truly not a VLC issue as full screen videos via VLC alone play fine. However with Quelea you’ll need to do the following in Win 10.

  1. Right-click the shortcut and select “Open File Location”
  2. Right-click the Quelea executable that should be highlighted and select “properties”
  3. Click the “Compatibility” tab
  4. Click on the button for “Change high DPI settings”
  5. Check the bottom box for “Override high DPI scalling behavior.”
  6. In the drop-down box select “System”
  7. Click Ok for each window and give it a try now!

Only remaining issues is that the video quickly flashes black when restarting the loop. :frowning:

1 Like

Thanks for posting a tutorial! As for the loop issues, you might want to take a look at this answer. There might also be some videos that work better than others - I not sure but believe that some of the included videos in Quelea might not be perfect loops. It also depends on your hardware how well VLC can loop a video.

I have same problem on MacBook Pro. I try to fix this issue by my self, but still nothing. So, if somebody know solution for Mac… I would be appreciated for any help!

I have same problem on MacBook Pro. I try to fix this issue by my self, but still nothing. So, if somebody know solution for Mac… I would be appreciated for any help!

Hi everyone! So, is enyone can tell me how to play video in full screen mode on MacBook Pro??? I have QUELEA 2019 version. HEEEEELP PLEASE!

Hi Nikolay,

I suppose you have the issue with the video only being visible in one corner? Or do you just want to hide the menubar?

I would suggest that you start by testing the latest CI release to see if anything has been done to resolve it. If it still doesn’t work, locate the debug log and send it to us so that we can check if there are any issues.

On my end, everything is working as expected.

Arvid

Hi, everyone,

I had same problem.
However, I found it how to use it.
I just changed the projector screen out into custom position.

And my quelea version is 21.

I hope it will help use this program.

Blessings,