Audio Recording issues on MacOS

Hi all! I’m new to Quelea, and am testing it for our church, alongside multiple other paid and unpaid solutions. Currently my opinion is that Quelea is a brilliant app, and absolutely perfect for us, except for two things:

  1. The install seems a little unstable on my machine (Mac Pro 5,1 running Mojave) I’ve yet to pin down any bugs, but it appears to be related to having the Options dialog open and switching OS focus away from Quelea.
  2. Audio recording does not work at all for me. I’ve poked around with it a bit, and can’t bring it to life.
    Can someone please let me know if I’m missing anything?

As I understand it, Quelea records in WAV, but can convert to MP3 if VLC Media player is installed. (Which it is)
In my experience, WAV is not particularly supported or encouraged on Apple devices. Is the recording feature even supposed to work at this stage…?

As it stands, I click the “Record Audio” button, (yes, my inputs are set up and tested correctly) the button changes to a duration readout; I click it again and it stops. I can’t find any output of any kind being produced or saved.

Any help or info would be much appreciated!

Do let us know if you are able to narrow down the bugs so that we know what to look for.

Yes, I’ve helped a church with a Mac setup recording with Quelea, so it should work. Have you remembered to set a path for storing the recordings in the options dialog? I think it should warn you if you haven’t, but just in case it wouldn’t have done that it might be worth double-checking. The recording should automatically be stored in the directory you’ve entered from the moment you start recording.

Thanks for your quick response, @ArvidNy!
I’ve been trying - unsuccessfully so far - to reproduce a crash that occurred multiple times with Quelea, in the first little while getting acquainted with the various programs I have been trialling.
Would you like me to send you the four crash reports I have retrieved from in Quelea’s log file?

As far as recordings go, I’ve triple-checked all my setup and config, audio sources, paths & VLC installation, all with no joy.

Do you have any suggestions as to how we could go about troubleshooting this issue?

Sure, all debug logs you can send us after experiencing any issues are greatly appreciated! Without any hints as to what’s happening, usually it’s a quite tedious job trying to find the error - especially if it’s a OS related bug and neither of us has a Mac to test it with.

If we start in that end, we can see what else we could try after that if the debug log wouldn’t show anything.

Alright, I’m back. I’ve uninstalled & reinstalled Quelea, re-set it up, double-checked everything, and recording is still not producing any files that I can find. Neither is it crashing. (yet)

I’ve also obtained the actual computer that we intend to use, a 2017 iMac 21.5", and installed Quelea on it as well. On the first start up of a fresh installation, I tried the recording feature.
Quelea threw a dialog instructing me to specify the recording path. (Good)
After setting the path, no recording file is evident.
I selected the ‘convert to MP3’ option - Quelea threw a dialog warning that VLC is not installed. (Good)
After installing VLC, still no recordings. (I have tried with the VLC application open)
Quelea has thus far not thrown any other relevant warnings, or produced any logs that I can find.

This is running on a fresh installation of MacOS 10.14.6 Mojave, with nothing unusual in the setup.

Also I do have four crash reports from the original installation on my personal Mac Pro, but I didn’t want to copy and paste them here, and can’t find how to upload them or message you directly. How is best to send the files to you?

I’ve just set your trust level to 1 which means that you should now be able to send personal messages to me if you click the username or profile picture, but I’m not sure if you can attach files there. Perhaps the best way for you would be to send an email to arvid at quelea dot org and I’ll look at the files. If you could send the debug log as well, even if no warning is shown, that would be helpful!